Cisco CCNA / CCNP Certification: OSPF ASBRs Explained And Illustrated

When I first started studying for my CCNP, some of the concepts of OSPF really confused me. This was especially true for the ASBR, stub areas, and total stub areas. Sure, I could memorize the LSA types associated with these devices and area types, but there just weren't any illustrations that explained exactly what was going on.

This CCNP tutorial shows an ASBR in operation, and also introduces you to a basic example of route redistribution. Don't worry, it gets more complicated. :)

Here's the network we'll be working with in this tutorial:

R5

|

R1

/

R2 R3

Networks:

R1 - R5 Ethernet Segment: 10.1.1.0 /24

R1 - R2 - R3 Serial Segment: 172.16.123.0 /24 (Preconfigured with OSPF)

R1 and R5 are running RIP over their common Ethernet segment, 10.1.1.0 /24. R5 has three loopbacks it will be advertising into the RIP domain.

R1 is also running OSPF, with R2 and R3 as neighbors. Even though R1 knows about the loopbacks on R5, its OSPF neighbors do not. R1 has these routes in its RIP routing table, and for OSPF neighbors to learn of these routes, route redistribution must be manually configured.

R5#conf t
R5(config)#router rip
R5(config-router)#version 2
R5(config-router)#no auto-summary
R5(config-router)#network 5.0.0.0
R5(config-router)#network 10.0.0.0

R1#conf t
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 10.0.0.0

R1#show ip route rip
5.0.0.0/24 is subnetted, 3 subnets
R 5.1.1.0 [120/1] via 10.1.1.5, 00:00:10, Ethernet0
R 5.2.1.0 [120/1] via 10.1.1.5, 00:00:10, Ethernet0
R 5.3.1.0 [120/1] via 10.1.1.5, 00:00:10, Ethernet0

R1 has a route for all three of R5's loopback interfaces, learned via RIP. R1 is also running OSPF, but its neighbors R2 and R3 don't know about these RIP routes:

R2#show ip route ospf

R2# < no output from show command means no routes! >

R3#show ip route ospf

R3#

Be careful when configuring redistribution use IOS Help to make sure you're not missing any vital options. IOS Help shows that there is a "subnets" option when redistributing RIP into OSPF. If that is left off, only classful networks are redistributed (as the router is kind enough to tell us). In this case, we have no classful networks, so there will be no redistribution. R2 will not see the RIP routes.

R1(config)#router ospf 1
R1(config-router)#redistribute rip ?

metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
route-map Route map reference
subnets Consider subnets for redistribution into OSPF
tag Set tag for routes redistributed into OSPF

R1(config-router)#redistribute rip
% Only classful networks will be redistributed

R2#show ip route ospf

R2#clear ip route *

R2#show ip route ospf

R2#

On R1, we'll now use the "subnets" option, and the RIP subnets are successfully redistributed into OSPF.

R1(config)#router ospf 1

R1(config-router)#redistribute rip subnets

R2 now sees the redistributed routes.

R2#show ip route ospf

5.0.0.0/24 is subnetted, 3 subnets

O E2 5.1.1.0 [110/20] via 172.12.123.1, 00:00:08, Serial0.123

O E2 5.2.1.0 [110/20] via 172.12.123.1, 00:00:08, Serial0.123

O E2 5.3.1.0 [110/20] via 172.12.123.1, 00:00:08, Serial0.123

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.1.1.0 [110/20] via 172.12.123.1, 00:00:08, Serial0.123

Notice that the routes are marked as "E2". The E indicates that these are external routes these are routes that were learned by OSPF via redistribution.

Naturally, you'll want to ping these networks to make sure you have two-way communication. Even though the routes to these loopbacks are in the routing table, pings fail:

R2#ping 5.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Keep this in mind when troubleshooting: It's not enough to have a route to a destination for pings to succeed there's got to be a path back. At this point, R5 doesn't know where the 172.12.123.0 network is, so there's no way the ping can get back. More route redistribution is necessary on R1.

Your first instinct may be to redistribute OSPF routes into RIP to make this work, but remember that the 172.12.123.0 /24 network isn't known to R1 via OSPF it's a directly connected network. We can redistribute connected networks into RIP to give R5 a route to 172.12.123.0 /24, which will give the ICMP packets a path back to R2, which will allow pings to succeed.

R1(config)#router rip

R1(config-router)#redistribute connected

R5#show ip route rip

1.0.0.0/32 is subnetted, 1 subnets

R 1.1.1.1 [120/1] via 10.1.1.1, 00:00:02, Ethernet0

172.12.0.0/24 is subnetted, 1 subnets

R 172.12.123.0 [120/1] via 10.1.1.1, 00:00:02, Ethernet0

R2#ping 5.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 5.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/76 ms

Performing this redistribution makes R1 an ASBR, as shown here with show ip ospf. This command even shows you what protocol(s) are being redistributed into OSPF.

R1#show ip ospf

Routing Process "ospf 1" with ID 1.1.1.1

Supports only single TOS(TOS0) routes

Supports opaque LSA

It is an autonomous system boundary router

Redistributing External Routes from,

rip, includes subnets in redistribution

Knowing exactly what the ASBR does and how to configure route redistribution are just a few of the many OSPF skills you'll need to earn your CCNP. Like any other Cisco skill, breaking a complex topic like OSPF down into smaller, manageable pieces is the best way to master these topics and pass the CCNP exams.

Keep watching The Bryant Advantage website for more free CCNA and CCNP tutorials!

To your success,
Chris Bryant
CCIE #12933
chris@thebryantadvantage.com

Chris Bryant, CCIE #12933, is the owner of The Bryant Advantage. The Bryant Advantage offers dozens of FREE CCNA, CCNP, and Home Lab tutorials and articles. The Bryant Advantage sells the world's most comprehensive CCNA Study Guide, and my exclusive Binary Math and Subnetting Mastery book. My CCNA Online Fast Track is the world's fastest-growing CCNA course. Get your CCNA and CCNP today at http://www.thebryantadvantage.com

Why Get a Microsoft MCSE Certification?

In the years of the dot com boom and bust, the Microsoft MCSE Certification has... Read More

Why Build Your Own Gaming Computer?

The best way to get the gaming computer that you want, that will provide optimum... Read More

How to Set Up Simple File Sharing WinXP

The first step is: Start > My DocumentsSo you have the My documents folder open.Second... Read More

5 Ways to Speed Up Your PC

No matter how fast your processor and regardless of how much ram you carry, there... Read More

Smart Apple iPod Tips and Techniques

Are you thinking of buying an Apple iPod? Or have you bought one?Almost everyone and... Read More

A Beginners Guide to Avoiding Viruses

"Aaaaaahhhhhh! I've been invaded by a virus!" Getting a virus means getting sick and no... Read More

Are You Well Protected?

Winter?the official start of the cold and flu season. Though, technically speaking, things got started... Read More

Make Windows XP Run Faster!

A friend told me: "My computer startup seems to be taking a long time. And... Read More

Cisco CCNA Certification: Five Things To Do DURING The Exam

There are plenty of articles out there about how to prepare for the CCNA exam.... Read More

Cisco Certification: Building Your Own Home Lab, Part I

CCNAs and CCNA candidates hear it all the time: ???Get some hands-on experience???. From my... Read More

Computer Geeks and Garden Gnomes

First and foremost before I begin my ranting it is worth mentioning that there are... Read More

Basic Computer Thermodynamics

That desk in front of you and everything else around you is made up of... Read More

Be Prepared in the Event Computer Disaster Strikes

ComputersBusinesses and individuals alike have all grown to rely on computers. The reliance is never... Read More

Is DVD Storage An Attractive Alternative For Your Computer Backup?

If you have a computer for home use or for your business and don't take... Read More

Help, I Need a New HDTV! (Part 3 of 5)

Feeling overwhelmed in selecting a new TV? With all the choices these days, you may... Read More

Image Conversion In Computers

JPEG, GIFF/JIFF, BMP, and TIFF are the most commonly used formats for storing still image... Read More

Virtual Memory - What is It?

I recently got an e-mail asking about virtual memory. The person who sent me the... Read More

How To Increase Computer Speed And Performance - Great Tips & Tricks

Many computer users are worried about their computer's performance. After spending lot of bucks, still... Read More

How Does a Palm Pilot Work?

Just The Facts, Ma'mPalm pilots are all the rage now. Everyone has a pda or... Read More

Customize Your Portable Player with an MP3 Player Accessory

Everywhere you look today people are listening to personal audio players. And many look for... Read More

JVCs First Three-Layer Combo-Disc Blu-Ray / DVD

JVC developed and used a high-performance reflective film to produce this revolutionary three layer structure.... Read More

Computer Performance Tips

Introduction In this article I will clearly spell out the most effective steps you can... Read More

How to Protect your PC from Spyware in the Cyber Age

Wouldn't you be shocked to find that your personal sensitive information, like files, credit card... Read More

Does Microsoft Show Hackers How To Attack?

After another security hole recently surfaced in Microsoft's Windows operating system, the software giant released... Read More

5 Steps to Remove Spyware for Free

Have you ever tried to remove Spyware off your PC only to find out it... Read More

Bluetooth Headphones For Your PDA

Nothing is worse than having to negotiate all kinds of cables with your many electronic... Read More

Connect Your IPAQ to Linux

Choose Not To ConformPalm pilots and pdas are constantly growing in the ways that people... Read More

Selecting the Perfect Big Screen TV

Selecting a TV isn't as easy as it used to be in years gone by.... Read More

FTP - File Transfer Protocol Explained

File Transfer Protocol (FTP) is a protocol that is part of the TCP/IP suite. It... Read More

How to Buy a Plasma Television Set

Most people think that all you have to do to purchase a new plasma television... Read More

Windows PDA Medical Software Benefits

PDA Medical BenefitsIf you are concerned about your medical history, the Internet has some great... Read More

Protect Your PC from Viruses, Worms & Trojans

Each of the items in the checklist below is part of a broad and easy... Read More

7 Reasons NOT to Take Your Laptop on Holiday!

Heading off on vacation soon?Then perhaps you're tempted to take your trusty laptop along for... Read More

How To Buy An MP3 Player

Are you looking for an MP3 player but am not sure which type and model... Read More

Favorite Things To Do With Home Technology

Save money. Save 10-15% on utility bills per month. Work with products that have a... Read More

MobiTV and Visual Stimulation Imput for Personal Cognitive Performance

Stimulus thru Caffiene or Visual Input?It appears that the Mobi TV feature for Cell Phones... Read More

Flow Text Around a Graphic in Microsoft Word

Flow Text Around a GraphicQuestion: I have inserted a photo in my Word document but... Read More

The Importance Of Email Backup

Viruses, software failures, power failures, human errors, hard drive failures are only a few examples... Read More

Some Thoughts on Choosing a Flash MP3 Player

Flash mp3 players come with an exciting array of features, and can be used for... Read More

Cisco Certification: The Most Important Cisco Study Youll Ever Do

All of us are familiar with the pyramids of Egypt. These magnificent structures have stood... Read More

Learn the Lost Art of Touch Typing

Computers have replaced typewriters, but two-finger, hunt-and-peck typing can never replace the touch typing of... Read More

Three Things You Can Do to Keep Your Computer Running at Maximum Performance

Although there are many things that can affect the performance of your computer, there are... Read More

Cisco Certification: Taking Your First Certification Exam

You???ve studied hard; you???ve practiced your configurations; you???ve used your flash cards over and over... Read More

Basic Diagnosis Guidelines for Your PC

Simone is exasperated. She has to work on her university assignment but her PC is... Read More

Bios Term

BIOS - Basic Input Output SystemThe central processing unit of a computer needs to communicate... Read More

Compare MP3 Players for the Coolest Features and Sweetest Deals

How can you compare mp3 players to be sure you're getting the best features and... Read More

How I Started Working With 3D Modeling Programs

So I'll start from the very beginning.One day I was surfing in the web and... Read More

Troubleshooting Computer Freeze (Lockup) Problems

How familiar does the following sound? Your computer was working fine, but then suddenly started... Read More

Put Order and Information into File Names

Unless you place your faith in internal search engine software or document databases... Read More

Home Electronics: The Facts About Plasma TV

Not so many years ago, homes across the country watched their favorite TV shows on... Read More